La page de modification du produit ne se charge pas lorsque j’essaie de modifier un produit à variantes

Problème

Lorsque vous essayez de modifier un produit à variantes, la page de modification ne se charge pas et n’affiche pas non plus d’erreurs.

Configuration

  • Retail POS pour Mac ou PC

Cause

Il manque des informations dans la valeur de la variante et il manque une valeur de la variante pour l’un des éléments de la variante.

Solution

La non-concordance du produit doit être corrigée par une importation CSV, réalisée en suivant les étapes ci-dessous :

  • Accédez à Catalog -> Products (catalogue -> produits).
  • Recherchez le produit concerné par son nom ou son alias.
  • Exportez le fichier CSV en cliquant sur Export List (exporter la liste).
  • Dans le fichier CSV, saisissez toutes les valeurs manquantes pour les éléments de la variante.
  • Supprimez les colonnes du niveau des stocks et enregistrez à nouveau le fichier au format CSV.
  • Importez à nouveau ce fichier dans votre page Product (produit) en cliquant sur Import (importer).

Une fois l’importation terminée, le produit pourra être modifié ou mis à jour.

Renseignements supplémentaires

Lorsqu’il manque des caractéristiques de variante ou que les caractéristiques de variante ne correspondent pas, une erreur s’affiche à l’écran lors de la tentative de modification du produit, sous la forme du message « Something went wrong with this product » (un problème est survenu avec ce produit). Ces problèmes sont abordés ci-dessous :

Avons-nous répondu à votre question?
Vous avez d’autres questions? Contactez-nous pour que nous puissions vous aider.