Error "Your statement is not ready yet" when trying to View Latest Statement

Problem

When clicking to View Latest Statement the below error is shown:

Screenshot_2020-02-03_at_13.09.02.png

Setup

  •  Vend for Mac or PC

Cause

This happens when a component like a Register or Outlet has been added after the latest billing period. This starts the next statement with that charge but the statement is not complete until the billing period renews.

Solution

Please reach out to Support from the Primary Admin or Billing Recipient email if you require a statement for the previous billing period or the current statement including the recent charges.