What iOS should my iPad run to work with Retail POS (X-Series)?

 Setup

  • Retail POS on iPad

Answer

To ensure you get the best experience using Retail POS on iPad, we recommend running Retail POS on iOS 14 and above, which is available on iPads released from 2014 onwards (see list of compatible iPad models here).

Retail POS still works on older iOS versions, however, all new feature releases, improvements and bug fixes are only available to newer iPad models, running iOS 14 and above. 

Additional Information 

Some iPad models that can support the latest updates,

  • iPad 9.7" 5th Gen
  • iPad Pro 9.7"
  • iPad Pro 10.5"
  • iPad Pro 11"
  • iPad Pro 12.9"

For more information, please check our links below.  

 

 

 

Did this answer your question?
Have more questions? Contact us so that we can help you out.