Why aren't my BigCommerce products importing into Retail POS (X-Series)?

Setup

  • Retail POS for Mac or PC
  • BigCommerce Integration

Cause

Products can fail to import for a few reasons:

  1. Products are set to invisible on BigCommerce
  2. A product is meant to have variants however the options have not been generated on BigCommerce
  3. A product on BigCommerce is using a SKU already assigned to a different product in Retail POS
  4. A product on BigCommerce is using a SKU that already exists in Retail POS with a different product name than what's assigned on BigCommerce
  5. The variant attribute amount exceeds Retail POS's maximum of three variant options

Solution

  • Review and correct affected products and attempt to reimport
  • If a second failure occurs, please contact Retail Support and we can assist with the problem 

Additional Information

  • If products are not corrected, orders containing products will not be displayed on Retail POS
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