Why was a product sold on Shopify which is out of stock on Vend?

Sumeet Singh
Updated


Problem

Sometimes the inventory between Vend and Shopify doesn't match and a customer purchases an item available on Shopify which is out of stock on Vend.

Setup

  • Vend for Mac or PC
  • Shopify Integration 

Cause 1

  • Rate limit - Updating a lot of products in Vend could result in rate-limiting the Shopify account which will stop receiving a request from our servers.

Solution

  • Avoid updating the whole product list at once via CSV or inventory count. We are unable to provide the exact number but updating 1500-2000 products via CSV should sync fine.

Cause 2

  • There are third-party plugins installed on Shopify which has permission to update the inventory which Shopify doesn't have a way to sync back to us. For example, Plugin A updated the inventory from 0 to 1 on Shopify and the customer purchased an item. The sale synced to Vend deducting the inventory from 0 to -1. This update will then sync back to Shopify updating the inventory from 0 to -1.

Solution

  • Please consider removing any plugin which has permission to update the inventory which Shopify.