Why are taxes not applying to my stock orders after syncing to Xero?

Anna Vi
Updated


Problem

Stock order invoice that is posted to Xero is not having the correct taxes applied. 

Setup

  • Vend for Mac or PC
  • Vend on iPad
  • Xero integration

Cause

The appropriate tax is not setup on the Purchase account in Xero.

Solution

  1. In Xero, click Accounting
  2. Click Chart of Accounts
  3. Search for the purchase account mapped in Vend
  4. Click on the name of the account 
  5. Under Tax, apply the appropriate Tax Type
  6. Click Save

Additional Information

Setting Up Matching Tax Rates with the Vend-Xero Integration