Customer account balance does not match between Vend and Xero

Setup

  • Vend for Mac or PC
  • Xero integration

Cause

  • On account sales are not syncing to Xero
  • Overpayments in Vend/Xero
  • Payments were applied in Xero and not synced to Vend

Solution

On account sales are not syncing to Xero

  1. In Vend, click Customers
  2. Find the affected customer
  3. Click View Sales History 
  4. Click the red Xero icon next to the on account sales that have not synced to post them to Xero

Overpayments in Vend/Xero

  • If there is an overpayment on an invoice in either Vend or Xero, this will not be able to sync between the two platforms and must be accounted for manually 

Payments were applied in Xero and not synced to Vend

  • If a payment is applied in Xero, it will have to be synced to Vend in the sales ledger

Additional Information

How do payments from on account sales sync between Vend and Xero?