Hi. How can we help?

Retail POS (X-Series) is not sending data to Xero

Setup

  • Retail POS for Mac or PC
  • Xero integration  

Cause

  • Errors preventing data from posting to Xero
  • Retail POS is linked to the wrong Xero account 

Solution

Errors preventing data from posting to Xero

  1. In Retail POS, click the Xero icon next to the data that is failing to post to Xero
  2. If an error appears, check the cause of the error
  3. If no error appears, data is not automatically posting to Xero

Retail POS is linked to the wrong Xero account 

  1. Click Setup
  2. Click Apps
  3. Click the pencil icon next to Xero
  4. Ensure the organization name in the bottom right corner matches your Xero organization name 

Additional Information

Register closures and on account sales are not automatically posting to Xero

Was this article helpful?

0 out of 4 found this helpful