Delay between Vend app and receipt printer


Latest update: - Lucia Palozzi

Problem

There is a delayed response time between tapping Print Receipt and receipt printing.  

Setup

  • Vend on iPad
  • Supported receipt printer

Cause

  • Poor internet connection
  • Out of date Vend app version/ iOS version 
  • Large file size images in the header and/or footer

Solution

Check Internet Speed

  1. Perform an internet speed test using this site.
  2. Check your results using this guide.  
  3. If the internet speed is suitable, proceed to 'Check Software Versions'

Check Software Versions

  1. Tap the iPad settings
  2. Tap General 
  3. Tap Software Update
  4. If your iPad requires a software update, tap Download and Install
  5. In the Vend app, open the left-hand menu
  6. Tap the green Online button
  7. Your Vend app version will appear on the bottom
  8. Check our latest version of the app here
  9. If the app is out of date, update your app in the App Store 
  10. If the issue persists once all software is up to date, proceed to 'Remove and Reinstall Printer'

Remove and Reinstall Printer

  1. In the Vend app, open the left-hand menu
  2. Tap Settings
  3. Tap Hardware
  4. Tap your printer name
  5. Tap Remove Printer
  6. Follow the steps for installing your printer model using these steps
  7. If the issue persists, proceed to 'Uninstall/Reinstall the Vend App'

Uninstall/Reinstall the Vend App

  1. Press and hold your finger on the Vend app icon
  2. Tap the 'x' on the top left corner of the app icon to uninstall
  3. Tap the App Store icon
  4. Search for the Vend register app
  5. Tap the app to download
  6. Follow the steps for installing your printer model using these steps

To remove the images from your header/footer:

  1. Click Setup
  2. Click Outlets & Registers
  3. Click the name of the template in use
  4. Scroll to the Header Information field
  5. Select the image by clicking and dragging over it like text
  6. Tap the backspace or delete key on your keyboard

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Additional Information

  • After uninstalling the Vend app, you will have to re-add any printers/payment processors you use with Vend
  • Make sure you have an Apple ID password and the password for your Vend account so you will be able to download the app again